Tuesday, August 31, 2010

What's your major malfunction?

Still no O.

It's CD 21 and I'm still showing Hi Fertility. I suppose I could be NOT ovulating this month, but that hasn't happened before.

Okay, the only thing I can think is that my O monitor or pee sticks malfunctioned. I suppose it could be user error and I peed incorrectly - under or over saturated the stick. 

Who knows? Who cares? 

What I do know is that we did the sexy thing on Aug 22, but with no follow up, because I don't know if or when I ovulated! How frustrating is that?

Has this happened to any other normally ovulating IF'er out there?

~Jem

7 comments:

Amy said...

Hi Jem, I did have a pregnancy stick malfunction on me - completely went blank right before it should have given me a result! - so I know about malfunctioning sticks, it definitely happens. I know it is frustrating. Annoying. :(

Ernie said...

Are you using a ClearBlue Easy fertility monitor? If so, you might want to try resetting it. I believe those instructions are in the FAQ part of the instruction manual.

My OB had put me on Estradiol for a month to try to straighten out my cycles (which used to be like clockwork), and for the month following that all I got were high fertility readings with no peak. I took Progesterone for 6 days, my period started, then the next cycle I was back to my normal readings with an O.

I hope your cycle or the monitor gets back on track!

Katie said...

Very strange. I hope your egg makes her appearance soon!

denise said...

I've missed ovulation on my Clearblue Easy OPKs before, and blood tests confirmed that I ovulated. The nurse at my RE's office says it happens from time to time. She said it's sometimes a simple thing like having had too much water on the day it would have turned positive.

Amber said...

Ugh, how frustrating! I have no advice, since I never O on my own. But I hope it goes one way or the other soon. The not knowing is awful!

bunny said...

This sounds deeply frustrating. It's interesting to read that the monitor can go haywire. Not interesting to you, no doubt, but good to know. It sound like you got the right stuff in the right place at the right time assuming it is a problem with the monitor, and that's something to cling to.

Kakunaa said...

I can't help...my O's are pointless. LOL. I hope you get back on track!